SOP for Developing Evidence Mapping Figures in Tableau
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Overall workflow
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1. Export data from Distiller
Step by step direction
· Open Distiller. Go to the ‘Reports’ tab at the top and click ‘Datarama’. In each tab in Datarama, do the following:
· ‘Report Settings’: 
· Leave ‘View online’ as is for now so you can preview your export as you go.
· ‘Bibliographic format’: Select an option from the dropdown. 
· Under ‘Data to display’ check ‘Lit inventory’.
· If you would like, click 'Run Report' just to see the results of your report thus far displayed in your browser.
· **Note: Avoid clicking the dark blue buttons at the bottom of the export and if you click into the data and open the form, be careful not to change data!
· ‘Advanced Options’:
· Uncheck 'Hide empty columns'. This ensures that columns without data (e.g., matrices or exposure routes not currently present in the dataset) will show up. It is important to have these columns in the Power Query in case a lit inventory update contains data in these fields.
· Keep the check on 'Merge sets by key' to maintain the structure of hierarchical forms.
· Under 'Merging options', uncheck ‘Do not merge’ and check 'Merge data but do not duplicate single forms with repeating forms'. This ensure that references reviewed at the same level by multiple people will be combined.
· 'Reference criteria': Do nothing here.
· 'Data criteria': Do nothing here.
· 'Reference Display Options':
· Check ‘Abstract’, ‘Label’ (if the RefID isn't the HERO ID), and ‘URL’ (thought usually will have to be replaced with the public facing URL).
· Ignore the 'Saved queries', 'Query history', ‘Keys', and 'Aggregate reports' tabs.
· Go back to 'Report Settings' and change ‘Report format’ to ‘Excel spreadsheet’ in the dropdown. At the bottom of the page, type a name for these report settings in the box, then click ‘Run Report’.
· An Excel file with your report will download and your saved report settings will appear under the ‘Saved queries’ tab.
· If data are added to or changed in the lit inventory, rerun the query and export an updated dataset with the same settings by doing the following:
· Open Distiller, go to ‘Reports’ > ‘Datarama’ > ‘Saved queries’ and click on the orange lightning bolt icon that says ‘Load and run’ next to the query you would like to rerun and export.
· Whether you have exported a new query or rerun an existing query, rename your file with in such a way that the contents are clear and it includes a date and time stamp (e.g., Chloroform_DistillerExport_12.20.19_9.43am).
· Scan for completeness and quality of the extraction. BLANK FIELDS AND DATA EXTRACTION ERRORS CANNOT BE FIXED IN TABLEAU.
· Carefully review the endpoints listed under health outcomes and the description of the results
· Once QC is complete, run a Datarama report, selecting Excel as the output file.
Best practices
· Address blank values in Distiller before or at the time of export. 
· [insert more here maybe, but I don’t really know Distiller]
QA checks to ask yourself
· Are there blank values in my Distiller export?
· Did I save the Datarama report so I can export an identical file if more data are added in Distiller?
· [insert more here]

2. Prepare data in Excel using Power Query
Data preparation workflow
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Prepare the Distiller export
· Open a new Excel file to be the master file in which you will run your power queries and which will feed into Tableau later.
· Copy all of the data from the raw Distiller export file into a tab in the master data source file. Re-name the worksheet containing data (e.g., Lit Inventory Data).
· Make the data into a table:
· Select all data on the worksheet.
· On the Home tab in the Styles box, select ‘Format as Table’ > choose a table style.
· In the pop-up, make sure the entire data table is selected and check the ‘My table has headers’ box. Click ‘OK’.
· In the Table Design tab, name the table (e.g., ‘LitInventoryTable’) in the white box under Properties.
· Save the file with the word MASTER on the end so that it is clear that this file is the master data file for Tableau (e.g., Chloroform_PowerQuery_Tableau_data _MASTER).
Load and run the base query in Power Query
Here you will pull the source data into a different tab using Power Query. This new tab (which is the output of a query) will serve as the source for all future queries in the data preparation process.
· In the Master Excel file, create the base query by doing the following:
· On the Data tab, select Get Data > From File > From Workbook
· Navigate to the file you are currently working in and choose the relevant table or worksheet tab listed on the left (e.g., LitInventoryTable). Navigate to the originial 
· Click ‘Transform Data’ at the bottom right of the Navigator window, which will open the ‘Power Query Editor’ window. Note that while a Power Query Editor window is open, changes cannot be made to the worksheets in the Excel file or any other Excel file.
· If the dataset has a column called ‘Has this study been QC’ed?’, filter to display only the studies with ‘yes’ (i.e., the studies that have undergone QC).
· On the right side of the window in the ‘Query Settings’ pane rename your query in the ‘Name’ field by adding ‘ – BASE’ to the end of the query name (e.g., the new query name will be LitInventoryTable-BASE). This indicates that this is a baseline query (will not be edited and will always reflect original data) which can be used for QA later.
· On the Home tab in the Power Query Editor, select ‘Close and Load.’ ‘Loading’ data in Power Query is the equivalent of saving a query. You must still save your Excel file.
· You should see the query you created listed in the ‘Queries & Connections’ pane on the right. If you do not see a ‘Queries & Connections’ pane, click ‘Queries & Connections’ on the Data tab.
· The query was loaded into a new worksheet of the workbook (probably named Sheet2). Rename the worksheet to match the query name (e.g., ‘LitInventoryTable-BASE)
Isolating evidence streams and unpivot columns
Here you will learn how to use Power Query to isolate data by evidence stream and unpivot columns when needed. You will need to unpivot data for any fields that are in more than one column in Excel, but should be in one column in Tableau (e.g., supplemental type, exposure, matrix). This will vary by project. Fields that just need to be combined (e.g., ‘Study Design_Animal’ and ‘Study Design_Human’ becoming ‘Study Design’) will not need to be unpivoted.
· In the Master Excel file, open the ‘Queries & Connection’ pane, right click on the name of the base query, and choose ‘Duplicate.’ This opens the Power Query Editor window.
· Rename the new query in the ‘Name’ field of the ‘Query Setting’ pane to ‘Animal Info’ or something to reflect that this query contains all data for a given evidence stream, for this example, animal data. Now create this query in the Power Query Editor:
· Filter the ‘Evidence Type’ column so that only the relevant evidence type (e.g., animal) is showing.
· You may want to rename the steps in the ‘Applied Steps’ box in the ‘Query Settings’ pane at right to keep track of your query steps. To do this, right click on the name of a step (e.g., ‘Filtered Rows’) and name it in a more descriptive way (e.g., Filtered to show animal).
· Select (ctrl+click) all columns containing human-specific data (e.g., Exposure Measurement, Population).
· Press ‘Delete’ on your keyboard or ‘Remove Columns’ in the Home tab.
· Rename the step in the ‘Applied Steps’ box in the ‘Query Settings’ pane at right. You may add additional notes about that step: right click on the step and select ‘Properties.’ This will open a box in which you can write comments.
· Rename the ‘Study Design_Animal’ column to ‘Study Design’: right click on the column header and select ‘Rename’ to change the name.
· Click ‘Close and Load’ in the top left of the Power Query Editor.
· Rename the output worksheet to match the query name (e.g., Animal Info).
· Repeat this process for each evidence stream.
· If your evidence stream contains data that that displayed across multiple columns, but are all the same category and should be in a single column, you will have to unpivot the columns (e.g., if Exposure-occupational, Exposure-dermal, and Exposure-inhalation are three separate columns instead of one column called ‘Exposure’). To unpivot data:
· Duplicate the query for an evidence stream for which you would like to unpivot data (e.g., human) and the Power Query Editor will open.
· Leave all previous steps in place. You will be adding new steps.
· This will ensure that rows with null in all instances of the category will be labeled as 'none' and will not be dropped from the unpivoting.
· In the Add Column tab, click ‘Custom Column’. In the ‘Custom column formula’ tab:
· Type ‘if ’ and in the ‘Available columns’ menu, double click on one of the columns you wish to unpivot (e.g., ‘Exposure Measurement --> biomonitoring’).
· Then type ‘ = null ’ and hit enter.
· On the next line, type ‘and ’, then double click another column you wish to unpivot. Repeat this until all columns are added.
· After the final column to be unpivoted is added, hit enter and type ‘then “none”’. Hit enter again and type ‘else null ’
· The final custom formula should look like this:
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· Click ‘OK’.
· Select (ctrl+click) all columns you would like to unpivot (e.g. all ‘exposure measurement’ columns) and click ‘Unpivot Columns’ in the Transform tab.
· Two new columns containing the pivoted data will appear at the far right end of the tabled called ‘Attribute’ and ‘Value’.
· Delete the ‘Attribute’ column and rename the ‘Value’ column so that it described the data in the column (e.g., ‘Exposure Measurement’).
· Repeat this steps for every group of columns that needs to be unpivoted (e.g., ‘matrix’).
· [bookmark: _Hlk26524277]Once you have completed all necessary unpivoting for a given evidence stream, select all the data and remove duplicate rows by clicking the dropdown for ‘Remove Row’ and selecting ‘Remove Duplicates from the Home tab.
· Click ‘Close and Load’ in the top left of the Power Query Editor Window.
· Repeat the process of isolating and unpivoting (if necessary) data from each evidence stream.

· Note: when this ‘unpivot’ action is performed, PowerQuery ONLY keeps those rows that HAVE data in the unpivoted columns. So any rows of data that are left blank in these columns are DELETED from the data set (this is why it’s important to extract SOMETHING into Distiller, even if it’s ‘N/A’ or ‘Not Reported’, instead of leaving the field blank). In this case, RefID 850 is deleted from the data because it’s blank in all ‘exposure measurement’ and ‘matrix’ columns. This row is appended manually to the ‘human’ data set using another query (see below). This appending step can be discarded if these data are updated in distiller to include a non-blank entry for the ‘exposure measurement’ and ‘matrix’ information.  
Download and prepare reference information
Here you will export reference information from HERO which will later be merged into the rest of the dataset.
· Export a .ris file from HERO for the HERO IDs of the studies in your evaluation and create an EndNote library.
· Check all reference in EndNote for proper formatting; fill in any missing information.
· Select all reference and copy formatted using a style that will let you paste into Excel.
· Paste the reference information int a new tab in the workbook and name it ‘Reference Info’.
Reassemble final datasheet for Tableau
Here you will learn how to reassemble the data from each evidence stream and the reference information to create one compete dataset for Tableau.
· Right click on one of your previously created queries for any evidence stream (e.g., human) and select ‘Edit’ to open the Power Query Editor Window. To add other evidence stream data:
· In the Home tab, select the dropdown next to ‘Append Queries’, then ‘Append Queries as New’.
· Choose the name of the other query (e.g., if you are editing the ‘human’ query, select the ‘animal’ query to append) in the ‘Table to append to the primary table’ dropdown menu, then click ‘OK’.
· Rename the new query in the ‘Name’ field of the ‘Query Setting’ pane to ‘MASTER DATA’ or something to reflect that this query will contain all data ready for Tableau.
· Click ‘Close and Load’ in the top left of the Power Query Editor Window.
· Reopen the Power Query Editor window for your MASTER DATA query. To create a new column with HERO URLs:
· In the Add Column tab, select ‘Custom Column’.
· In the ‘New Column Name’ box, type ‘Public URL Base’; after the = in the box below, type “https://hero.epa.gov/hero/index.cfm/reference/details/reference_id/” (including quotation marks).
· Click ‘OK’. Rename this step to indicate that it contains the public URL base.
· Select the ‘Public URL Base’ column, then ctrl+click the ‘RefID’ column (order matters). In the Add Column tab, click ‘Merge Columns.
· In the pop-up window, keep Separator as ‘None’ and name your new column ‘Public URL Final’. Click ‘OK’.
· Select the ‘Public URL Base’ column and click delete on your keyboard.
· If you would like to create a field with the private HERO URLs, repeat these steps using this URL: https://heronet.epa.gov/heronet/index.cfm/reference/details/reference_id/
· Click ‘Close and Load’ in the top left of the Power Query Editor Window.
·  To add data from the Reference Info tab:
· From the blank drop down, choose ‘Reference Info’ (or the name of the query with reference data). In the preview window below, click on the ‘RefID’ column to highlight it (highlighting the RefID column in both datasets tells Excel to use this value as a lookup in each data set).
· Choose ‘Left Outer’ from the ‘Join Kind’ drop down menu (this will keep all rows from the Master data and only add matching information from the Reference Info query).
· Click ‘OK’.
· A new column will appear appended to the far right of the data table in the Power Query Editor populated with the value ‘Table’ all the way down the dataset. Click the small button (looks like 2 diverging arrows) in the column header:
[image: ]
· In the drop-down menu, make sure the columns you want to KEEP in the Reference Info dataset are checked in the list (e.g., uncheck ‘RefID’ since it is already included in the Master dataset). Uncheck ‘Use original column name as prefix’. 
· Click ‘OK’. Reference info columns have now been appended to the dataset.
· Click ‘Close and Load’ in the top left of the Power Query Editor Window.
· Rename the new worksheet to match the query name.
To update your queries with new data
· Download your most up-to-date export from Distiller and save the file with a time and date stamp.
· Copy and paste the data from your Distiller file into the Lit Inventory Data tab in the Master Excel file.
· Open your Master query/Tableau data file and in the Data tab, click ‘Refresh All’ and all of your queries should refresh, pulling in the most recent data that you copied into the master source data file.
· Re-save the updated query/Tableau data file as Master Tableau file.
3. Create visuals in Tableau
Create a new project in Tableau
· [bookmark: _GoBack]Open Tableau Public on your computer and load the data from your Master Tableau datasheet in your Power Query file by doing the following:
· Open Tableau and under ‘Connect’ > ‘To a File’ click ‘Microsoft Excel’. Navigate to and choose the Excel workbook where you performed the Power Query.
· On the Tableau ‘Data Source’ page, click and drag the worksheet that contains your master Tableau data (e.g., MASTER DATA) onto the ‘Drag sheets here’ area.
Create the heat map
This section describes how to create a heatmap for an evidence stream of choice.
· Go to the tab labeled ‘Sheet 1’. Click and drag the dimension (in blue) called ‘Evidence Type’ to the ‘Filters’ card and drop it there. 
· A box will pop up and ask you to select a way of filtering the data. Select the evidence stream you would like to use for this heatmap (e.g., Animal). Click ‘Apply’ and ‘OK’.
· Click and drag the dimension called ‘Health System’ to the empty box to the right of the word ‘Rows’.
· Click and drag the dimension called ‘Study Design’ to the empty box to the right of the word ‘Columns’.
· You may want to add additional subcategories to the columns, such as ‘Species’ for animals or ‘Study Population’ for humans. To do this, click the subcategory you would like to include and drag and drop it to the right of the ‘Study Design’ dimension.
· Click the measure (in green) called ‘RefID’ and drag and drop it onto the ‘Text’ box in the ‘Marks’ card. It will appear in green below and the default operation will be ‘SUM’.
· Right click on the green pill that says ‘SUM(Refid)’ and go to ‘Measure’ and select ‘Count (Distinct)’.
· In the ‘Show Me’ pane at right, choose the ‘Highlight tables’ option in the upper right corner. This will turn your data into a heat map.
· If this rearranges what is in rows vs. columns, click and drag the blue pills in the rows/columns field to create the heatmap you want.
· [bookmark: _Hlk29197332]To edit the tool tip for this visual:   
· Double click on the ‘Tooltip’ button on the ‘Marks’ card to edit the tooltip.
· Type the following in the editing window for animal or human data respectively, including a tab after each colon to align the column:
	For animal data, type:
	For human data, type:

	<CNTD(Refid)> Study(ies)
Health System: <Health System>
Species:              <Species>
Study Design:    <Study Design>
	<CNTD(Refid)> Study(ies)
Health System: <Health System>
Population:       <Population>
Study Design:    <Study Design>


· The < > around certain words indicate to Tableau to pull data from that field. These fields should turn gray after you type the name within < >.
· If a field does not appear in the visual, but you would like it to appear in the tooltip, click and drag it to ‘Tooltip’ button on the ‘Marks’ card. Include ATTR( ) around the field name when editing the tooltip text. 
·  Uncheck the ‘Include command buttons’ box. Click OK.
· To clean up your heatmap:
· Right click on the ‘Health Systems’ header and select ‘Hide Field Labels for Rows’.
· Right click on the ‘Study Design/Species’ header and select ‘Hide Field Labels for Columns’.
· Go to the ‘Analytics’ tab on the pane at left and under ‘Summarize’, select ‘Totals’ to display grand totals. If subtotals appear, go to ‘Analysis’ > ‘Totals’ > ‘Remove All Subtotals’ to remove.
· If you would like to center data, go to ‘Format’ > ‘Alignment’ and select the ‘Sheet’ tab in the pane at left. Under ‘Default’ > ‘Pane’, choose center align from the dropdown.
· Remove the title by right clicking on the title that says ‘Sheet 1’ and click ‘Hide Title’.
· Rename your worksheet to reflect your viz (e.g., Animal Heatmap) by right clicking the tab at the bottom that says, ‘Sheet 1’ and renaming.
· To edit colors, double click on the color range bar at right (may be hiding behind the ‘Show Me’ pane) and change color palette, if desired.
· Repeat this process for each evidence stream so that each evidence stream has its own heatmap.

· Change “Health System_Comment” to “Outcomes/Endpoint” by right clicking and renaming
· Change Nel and Lel to NEL and LEL
· Create a new sheet and set up visualizations. Instructions for creating some common types of visualization (including graphics that can be used as guides) are listed on the following pages.
· To export graphics for use in publication: Click on File -> Export as PowerPoint
· To export graphics to Tableau Public: 
· At the top of the Data Source tab, select “Extract” at the top right corner of the page.
· Return to the visual and select Server -> Tableau Public -> Save to Tableau Public.
Heat map of evidence types:
· Drag “Study design” and “Evidence types” to the columns, and “Health system” to the rows.
· Drag “Number of records” (listed at the bottom of the left-hand column under Measures) to the box labeled “Color” under Marks.  This will populate the heat map with a color scale. 
· Add numbers to the heat map by clicking on the figure and selecting all, and then right clicking and selecting “Mark label” -> “Always show”.
· If you don’t want to show all study designs or health systems in this figure, you can drag “Study design” or “Health system” to the Filters box. Select only the health outcomes or study designs you want to include.  
· e.g. In the graphic below, the information is filtered by “Health system” so that ADME data is not shown.  
· Filters can be adjusted or removed by clicking on the filter and selecting “Edit Filter” or “Remove”. 
· Adjust column widths and/or heights so that column and row names are legible. 
· Colors on the heat map can be changed by right clicking on the legend and selecting “Edit colors”.
· Format as desired 
· e.g. Headers can be deleted.  Font can be adjusted by right clicking and selecting Format.
Some heat map variations:
· If you only want to show one evidence type (human or animal) on the heat map, drag “Evidence type” to the box labeled “Filters”. Select the type of evidence you want to include.
· See additional example graphic below 
· If you are evaluating multiple chemical forms, you may want to differentiate the chemical forms in this heat map.  You can do this by dragging “Chemical Name” to the rows.
· See additional example graphic below

Create the reference list
Here you will learn how to create a reference list in Tableau.
· Create a new worksheet by clicking the ‘New Worksheet’ icon (square with bar chart and +) at the bottom of Tableau.
· Click and drag the dimension (in blue) called ‘Evidence Type’ to the ‘Filters’ card and drop it there. 
· A box will pop up and ask you to select a way of filtering the data. Select the evidence stream you would like to use for this heatmap (e.g., Animal). Click ‘Apply’ and ‘OK’.
· Click and drag the dimension that contains short reference information (i.e., Smith et al. (2010)) to the empty box to the right of the word ‘Rows’.
· To change the ‘Abc’ to a shape and color:
· In the dropdown menu in the ‘Marks’ card, select ‘Shape’. 
· Click on the ‘Shape’ box in the ‘Marks’ card and select ‘More shapes…’   
· Click on the ‘Color’ box in the ‘Marks’ card and choose a color for the shapes.
· To edit the tool tip for this visual:   
· Double click on the ‘Tooltip’ button on the ‘Marks’ card to edit the tooltip.
· Type <Bibliography> in the editing window to pull in the full citation and <URL> to pull in the URL. They should become highlighted in gray. Select ‘Tableau Bold’ as the font.
· Uncheck the ‘Include command buttons’ box. Click OK.
· To clean up the references list:
· Right click on the reference column header and select ‘Hide Field Labels for Rows’.
· Remove the title by right clicking on the title that says ‘Sheet 2’ and click ‘Hide Title’.
· Rename your worksheet to reflect your viz (e.g., Animal References) by right clicking the tab at the bottom that says, ‘Sheet 2’ and renaming.
· Repeat this process for each evidence stream so that each evidence stream has its own reference list.
Create the table of study details  
In this section, you will learn the mechanics of how to build the Study Details table in Tableau, as well as best practices for what data to display.
· Create a new worksheet by clicking the ‘New Worksheet’ icon (square with bar chart and +) at the bottom of Tableau.
· Click and drag the dimension called ‘Evidence Type’ to the ‘Filters’ card and drop it there. 
· A box will pop up and ask you to select a way of filtering the data. Select the evidence stream you would like to use for this heatmap (e.g., Animal). Click ‘Apply’ and ‘OK’.
· Click and drag the dimensions that you would like to display to the empty box to the right of the word ‘Rows’.
· Arrange the dimensions from left to right to reflect the order in which you would like them to display in the Study Details table.
· Typically, ‘Health Systems’ is displayed farthest to the left, then ‘Study Design’, with each column getting more specific as you go to the right. ‘Results comment’ should be displayed the farthest to the right. 
· Click and drag “Results animal” to the box labeled “Text” under Marks.  This will populate the final column with a description of the study results. 
· [write instructions about how to get the colored squares to appear, but idk with what data!!]
· If you want to narrow any of the types of information you are showing in the table, you can drag that information to the Filters box. 
· e.g. In the graphic below, the information is filtered by “Study design” so that only subchronic studies are shown, and by “Health system” so that ADME data is not shown.  
· Filters can be adjusted or removed by clicking on the filter and selecting “Edit Filter” or “Remove”. 
· To edit the tool tip for the table:   
· Double click on the ‘Tooltip’ button on the ‘Marks’ card to edit the tooltip.
· All fields displayed on the table will appear in the editing window. Type <Reference> above them to display the short citation at the top of the tool top. Select ‘Tableau Bold’ as the font.
· [Do we have a recommended order in which to arrange info in the tool tip? Best practices?]
· [What other fields besides what’s on the table should be displayed here? Also best practices for this?]
· Change the font of the text labels in the left column to ‘Tableau Bold’ and make all font black.
· Uncheck the ‘Include command buttons’ box. Click OK.
· To clean up the Study Details table:
· Remove the title by right clicking on the title that says ‘Sheet 3’ and click ‘Hide Title’.
· Rename your worksheet to reflect your viz (e.g., Animal Details) by right clicking the tab at the bottom that says, ‘Sheet 3’ and renaming.
· Repeat this process for each evidence stream so that each evidence stream has its own Study Details table.
Human
· Drag all information you want to show to the rows.  Arrange in the order that you want the rows to appear.
· If you want more than 6 rows in the table, go to “Analysis” -> “Table Layout” -> “Advanced”.  Increase the number of rows/columns to the maximum.
· Drag “Evidence type” to the Filters box and select Human. This will filter the results so that only human data is shown.
· If you want to narrow any of the types of information you are showing in the table, you can drag that information to Filters. 
· e.g. In the graphic below, the information is filtered by “Study design” so that only selected types of epidemiological study designs are shown.
· Filters can be adjusted or removed by clicking on the filter and selecting “Edit Filter” or “Remove”. 
· To add a color code for any additional information you want to show in the table, drag that information from the left-hand column to the box labeled “Color” under Marks.  
· e.g. In the graphic below, a color code was added for the type of results observed (adverse outcomes, potentially beneficial relationship, or no effects reported).  
· The colors can be changed by right clicking on the legend and selecting “Edit colors”.
· To make additional information appear when you hover above the color coding, drag that information to the box labeled “Tooltip” under Marks.  
· e.g. In the graphic below, you will see Main Study Findings, Exposure Measurement Comments, and Outcomes/Endpoints when you hover over the color coding.
· Adjust column widths and/or heights so that the contents of the table are legible. 
· Format as desired 
· e.g. Headers can be deleted.  Font can be adjusted by right clicking and selecting Format.
Animal
· To make additional information appear when you hover above the results, drag that information to the box labeled “Tooltip” under Marks.  
· e.g. In the graphic below, you will see Outcomes/Endpoints, Dosing Duration, and Study Design when you hover over the results.
Compile all data visualizations on a dashboard
Here you will learn how to combine the three visualizations you just made (heatmap, reference list, and study details table) on one dashboard for that evidence stream.
· Create a dashboard by clicking the ‘New Dashboard’ icon (square divided in quarters and +) at the bottom of Tableau.
· From the dropdown menu under ‘Size’ select ‘Fixed size’ from the first dropdown menu and ‘Generic Desktop 1366 x 768’ from the next dropdown menu. This sets the width and height of your dashboard in pixels.
· Your sheets will appear in the pane on the left. Below the sheets, the ‘Objects’ box contains the vertical and horizontal container, text box, image, and blank functions, all of which you will use.
· [Should I go into more depth about those?]
· I don’t really know the recommended order for this.
· Adjust container size such that…
· [Would this also be more of ‘style guide’ stuff?]
· To edit a text box, double click on the text box:
· Change the title to reflect the subject of the dashboard (e.g., if it’s animal data on 1-Naphthol, call the dashboard ‘Toxicological Studies Examining Exposure to 1-Naphthol by Study Design and Dosing Duration, and Health System). Make the font size 12, Tableau Bold. Make subtitles font size 11, Tableau Semibold.
· Under the ‘Layout’ pane at left, click Background > More colors… and put in the RGB values for the color you want (e.g. light green for titles is 179, 224, 166 and for subtitles is 221, 239, 214)
· To clean up the dashboard:
· Adjust the size of each figure and box by clicking and dragging the borders. All title boxes should be 40 pixels in height, have 4 pixels of ‘Outer Padding’, and 5 pixels of ‘Inner Padding’ on all sides.
· Ideally, adjust the sizes such that the entire heatmap is visible on the dashboard without scrolling.
· If titles are visible for each viz, right click on the title and select ‘Hide Title’.
· Right click on each dashboard tab and click ‘Hide All Sheets’. This will hide all sheets with figures that are on the dashboard.
· Rename the dashboard to reflect the content (e.g., Animal Studies) by right clicking the tab at the bottom that says ‘Dashboard 1’ and renaming.
· 
Create a ReadMe tab
· Just create it… copy from elsewhere?
· Add images? 




[Here there use to be a series of screenshots but I pulled them into another document]
Update Tableau with new data
· Open the Tableau workbook.
· Go to the Data tab, hover over the name of your data source that will appear in the dropdown, click ‘Edit data source…’ from the next dropdown.
· Navigate to and choose your Master Excel file.
· Click on the ‘Data Source’ tab at the bottom and make sure your worksheet called ‘MASTER DATA’ is displayed above. 
· You may need to address missing fields, if there were fields in the old dataset that are not in the new one.
· Under Dimensions and Measures, delete any fields with a red exclamation point beside them; this warning indicates that they are no longer in the new dataset.
· Check all of your visuals for errors and update if necessary.
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Stacked bar chart:
· Drag the main category of information you want to show on the x-axis to the columns 
· e.g. Chemical Name, as shown in the graphic
· Drag the information you want to use to stratify the bars to the box labeled “Color” under Marks
· e.g. Species, as shown in the graphic
· Drag Sum (listed at the bottom of the left-hand column under Measures) to the rows. This will populate the bar chart by showing the number of records.
· If you want to narrow any of the types of information you are showing in the chart, you can drag that information to the Filters box. 
· e.g. In the graphic below, the information is filtered by “Evidence type” so that only information from animal studies is shown.
· Filters can be adjusted or removed by clicking on the filter and selecting “Edit Filter” or “Remove”. 
· To sort the bar chart from highest to lowest number of records, click on the y-axis label. 
· You can rearrange the stacked bars by dragging the items in the legend.
· Adjust the dimensions of the figure as desired by dragging the x or y-axis.
· Format as desired 
· e.g. Headers can be deleted.  Font can be adjusted by right clicking and selecting Format.
Example graphic of a stacked bar chart:
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Troubleshooting Tableau figures:
Differentiating lines of data:  
If two lines in a table show the same information, Tableau will condense these lines into one unless you find a way to differentiate them.  You can recognize that this is happening because the results column will show up as “….”.
For example, in this table, the reproductive data for F0 and F1 generations in the study by Domingo et al. is condensed into one line because the study name, route of exposure, sex, dose levels, health system, etc is the same for both generations.  The results column for reproductive effects shows up as “….”:
[image: ]
You can fix this problem by adding a column for generation:
[image: ]
Tableau will also condense data when two studies have the same name (i.e. same authors and year).  If you have multiple studies with the same name, you can prevent this problem by adjusting the names of the studies in Distiller to add a letter after the year (e.g. 2019a, 2019b). 

Fixing errors in spreadsheet:  
When making figures in Tableau, you’ll likely find minor corrections that need to be made to your spreadsheets and/or the data in Distiller. You can deal with this without having to remake your figures by closing Tableau and fixing the errors in your spreadsheets and/or Distiller.  As long as the Excel file name and location do not change, you can reopen the Tableau file and your figures will appear with the corrected data. 


4. Common Questions & Answers
If there is no vertical line in your heatmap separating the column of health systems from the data, go to: ‘Format’ > ‘Borders’ and under the ‘Sheet’ tab, go to ‘Column Divider’ > ‘Pane’ and from the dropdown, click the solid line.
To duplicate a sheet, either right click on the sheet tab and click ‘duplicate’ or ctrl+click the sheet tab and drag it to either side. You may want to do this if you would like to make a sheet for one evidence stream that is based on a previously created sheet that is filtered by evidence stream. You would duplicate the sheet and change how it is filtered.




5. Training and Troubleshooting Resources
For training on Tableau:
Please see the Resources section of the Tableau Public website for training videos, exercises, and sample datasets with which you can follow along as you work through the video tutorials.
Basics on how to create a dashboard: https://help.tableau.com/current/pro/desktop/en-us/dashboards_create.htm
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